Issue with Web Application
Incident Report for Cambly
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 15:55 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2024 - 14:33 PDT
Investigating
There is a fairly significant issue with our web application (website). We have identified the problem and a fix should be live in the next 20 minutes.
Posted Apr 12, 2024 - 13:52 PDT