Cambly Application Issues

Incident Report for Cambly

Resolved

The incident with our provider, AWS, has been resolved, and their systems are back to normal. All Cambly services have been fully restored.
Posted Oct 20, 2025 - 16:00 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:25 PDT

Monitoring

We are continuing to monitor the ongoing incident with our provider, AWS. Some users may experience issues when using Cambly. AWS is actively working on a fix and our services will be restored once their systems are back online.
Posted Oct 20, 2025 - 08:23 PDT
This incident affected: Cambly Server.