Cambly is Down

Incident Report for Cambly

Resolved

This incident has been resolved.
Posted Apr 19, 2023 - 17:41 PDT

Update

Cambly might be slow to load
Posted Apr 19, 2023 - 17:38 PDT

Investigating

We are currently investigating this issue.
Posted Apr 19, 2023 - 17:34 PDT
This incident affected: Text Chat (In-Session Messaging, Out-of-Session Messaging), Cambly Server, Video Chat, and Cambly Web (Login).