Users having trouble joining lessons and sending messages

Incident Report for Cambly

Resolved

This incident has been resolved.
Posted Sep 08, 2022 - 12:02 PDT

Update

We are continuing to investigate this issue.
Posted Sep 08, 2022 - 12:02 PDT

Investigating

We are currently investigating this issue.
Posted Sep 08, 2022 - 11:44 PDT