Investigating Connectivity Issues
Incident Report for Cambly
Resolved
We thoroughly investigated remaining connection issues from tutors and determined that the issues with Cambly's servers were resolved as reported in the May 5-11 incident: https://status.cambly.com/incidents/32tpmgk6krbs

The remaining connection issues we've seen have been attributed to a couple notable causes beyond the typical connection issues we ordinarily see on the platform:
1. On May 10th 10am UTC, we re-introduced free trials for students on Cambly. Free trial students are more likely to have connection issues than subscribed students, so the effect to the tutor is that more calls will fail to connect as they take more calls from free trial students. The tutors themselves have a functional connection in this case.
2. We noticed a few tutors who couldn't couldn't connect due to an issue with Windows that prevents all web browsers on their computer from access the camera. Cambly and other in-browser video chat services like Google Meet didn't work, but non-browser-based video chat like Zoom worked fine. Restarting the computer fixed the issue for tutors encountering this specific problem. We don't think this is a new issue, but we were able to narrow down the root cause as part of our broader investigation into connection issues.

Thank you to all the tutors who jumped on calls with our team to help identify the original incident and verify that things are working as expected on Cambly's system afterwards. We apologize again for any inconvenience during the outage on May 5th. We also understand that video chat connection issues can always occur outside of the incidents reported on this page, so feel free to contact support if you need help troubleshooting your connection.
Posted May 18, 2022 - 13:44 PDT
Update
We're continuing to investigate and we suspect the issue may be impacting some tutors who recently updated Windows and preventing them from answering calls from students. We've been troubleshooting with some tutors, and restarting their computer fixed the issue. We're continuing to investigate and will post updates as we have them. Thank you to all the tutors who have been on calls with the team to help track down the issue.
Posted May 13, 2022 - 14:54 PDT
Update
We are continuing to investigate this issue. The investigation includes cases where the website loads, but calls do not connect.
Posted May 13, 2022 - 13:26 PDT
Investigating
We're investigating issues loading our website for some users.
Posted May 12, 2022 - 16:45 PDT
This incident affected: Cambly Server and Video Chat.