Cambly Outage

Incident Report for Cambly

Resolved

Cambly is available again. We'll be following up with our platform provider to discuss how we can prevent future incidents.
Posted Oct 21, 2022 - 20:15 PDT

Investigating

We experienced another DDoS attack. It seems to already be recovering.
Posted Oct 21, 2022 - 20:08 PDT