Cambly Outage

Incident Report for Cambly

Resolved

We found the issue and applied a fix.
Posted Nov 10, 2022 - 12:49 PST

Investigating

We are currently investigating this issue.
Posted Nov 10, 2022 - 12:31 PST