Apple Login Not Available
Incident Report for Cambly
Resolved
Apple Login was fixed at 10:15am UTC.
Posted Jan 12, 2021 - 08:38 PST
Identified
We've confirmed that Apple Login is broken for other websites as well. Until Apple releases a fix, the best solution is to reset your password (https://www.cambly.com/student/resetPassword) and use password login.
Posted Jan 12, 2021 - 01:53 PST
Update
For anyone that is unable to login, you can use the "Forgot your Password?" page (https://www.cambly.com/student/resetPassword) to reset your password and login even if you have never set a password.
Posted Jan 12, 2021 - 01:40 PST
Investigating
We're investigating what appears to be an outage with Apple Login.
Posted Jan 12, 2021 - 01:35 PST