Incorrect Tutor Balances
Incident Report for Cambly
Resolved
We've fixed the display issue with tutor balances. Your balance displayed is now correct.

For tutors that were affected, you may see a "failed" payment on your payment history. This payment can be ignored - it was not initiated and did not affect your balance.

We apologize for any confusion this caused.
Posted Aug 17, 2023 - 17:15 PDT
Identified
We are aware that some tutor balances are displaying incorrect. We are working to correct this display issue. Actual balances are not affected.
Posted Aug 17, 2023 - 14:39 PDT