Cambly website is slow to load
Incident Report for Cambly
Resolved
We have restarted the server that was causing slow load times and errors.
Posted Nov 24, 2024 - 03:44 PST
Investigating
We are investigating slow load times.
Posted Nov 24, 2024 - 03:02 PST